注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

老法师

可以跟有庄的股票谈对象,但不能成亲,赚了钱就跑,千万不能从一而终。

 
 
 

日志

 
 

【转载】选股公式  

2015-04-21 15:14:14|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
本文转载自ry0623《选股公式》

{逆势买入}
Var1b:=DMA(CLOSE,VOL/MA(vol,4)/4);
Var2b:=DMA(CLOSE,VOL/MA(VOL,32)/32);
Var3b:=(CLOSE-Var1b)/Var1b*100<-8;
Var4b:=(Var1b-Var2b)/Var2b*100<-21;
逆势买入:if(Var3b AND Var4b  AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05,45,0),stick,linethick3,colorf00ff0;
drawtext(逆势买入,40,'逆势买入'),colorf0f000;


============================
{龙战四海:99%成功率,选股条件:龙战四海=65}
Var1c:=REF(OPEN,1)<REF(OPEN,2);
Var2c:=REF(CLOSE,1)<REF(CLOSE,2);
Var3c:=REF(LOW,1)<REF(LOW,2);
Var4c:=OPEN>REF(CLOSE,1) AND OPEN/REF(CLOSE,1)>=1.03;
Var5c:=CLOSE>OPEN AND CLOSE/OPEN>1.03;
Var6c:=Var1c AND Var2c AND Var3c AND Var4c AND Var5c;
Var7c:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
Var8c:=REF(CLOSE,1);
Var9c:=SMA(MAX(CLOSE-Var8c,0),5,1)/SMA(ABS(CLOSE-Var8c),5,1)*100;
VarA:=COUNT(Var9c<20,20)>=1;
VarB:=Var7c AND VarA;
龙战四海:if(VarB AND Var6c,65,0),colorf0f000;
drawtext(龙战四海,55,'龙战四海'),colorf00ff0;
{股价经历了相当长一段时间下跌后,做空能量逐渐消耗。最后在星位跳空下跌,标志着市场最后一线希望破灭,但与此同时行情在绝望之中诞生,伴随第三天股价跳空上涨,一轮触底回升行情就此展开。}


============================
{云梯}
{参数描述: P1(0,100,20)P(0.9,1.1,1.088)P2(1,300,5)}
Var1d:=REF(INDEXC,1);
Var2d:=SMA(MAX(INDEXC-Var1d,0),6,1)/SMA(ABS(INDEXC-Var1d),6,1)*100;
Var3d:=COUNT(Var2d<20,20)>=3 OR Var2d<=1.088;
Var4d:=Var2d>=75 AND Var2d<=90;
Var5d:=Var3d OR Var4d;
Var6d:=SUM(VOL/CAPITAL,0)/BARSCOUNT(CLOSE);
Var7d:=VOL/(CAPITAL*Var6d);
Var8d:=MA(Var7d,5);
Var9d:=100*Var6d;
VarA1:=Var8d-Var9d;
VarB1:=(HIGH+LOW)/2;
VarC1:=VOL/CAPITAL/SMA(VOL/CAPITAL,25,2);
VarD1:=MA(VarB1*VarC1,25);
云梯:if(Var3d AND CLOSE>=REF(CLOSE,1) AND INDEXC>=0.98*REF(INDEXC,1) AND CLOSE<=1.45*LLV(CLOSE,55) AND VarA1>0 AND VarD1>0,30,0),stick,color00ff00;
drawtext(云梯,25,'云梯'),colorwhite;


============================
{旭日东升 }
Var1f:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
Var2f:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
Var3f:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
旭日东升:if(Var1f AND Var2f AND CROSS(Var3f,79) AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)<0.05
AND VOL>MA(VOL,23),40,0),color000999 ;
drawtext(旭日东升,35,'旭日东升'),colorf0f000;

============================
{冲灵剑法}
Var1g:=COST(999999999999999999999999999);
Var2g:=EMA(CLOSE,5);
Var3g:=EMA(CLOSE,10);
Var4g:=CROSS(Var2g,Var3g);
Var5g:=VOL>1.05*MA(VOL,5) AND VOL<5*REF(VOL,1);
Var6g:=(CLOSE-OPEN)/OPEN;
Var7g:=(HIGH-CLOSE)/(CLOSE-OPEN);
Var8g:=(OPEN-LOW)/(CLOSE-OPEN);
Var9g:=Var7g<0.8 AND Var8g<0.8;
VarA2:=Var6g>0.04;
VarB2:=CROSS(MA(CLOSE,5),MA(CLOSE,10)) OR MA(CLOSE,5)-MA(CLOSE,10)<0 AND ABS(MA(CLOSE,5)-MA(CLOSE,10))/MA(CLOSE,10)<0.02 AND MA(CLOSE,5)-MA(CLOSE,10)>REF(MA(CLOSE,5)-MA(CLOSE,10),1);
VarC2:=Var4g AND Var5g AND Var9g AND VarA2 AND VarB2;
VarD2:=COUNT(VarC2,30);
冲灵剑法:if(VarC2 AND VarD2=1,80,0),stick,linethick2,colorf0f000;
drawtext(冲灵剑法,70,'冲灵剑法'),color2255ff;


============================
{江恩回调选股}
a1:=hhv(high,50)/llv(low,100)>1.5;
a2:=(hhv(high,50)-low)/(hhv(high,50)-llv(low,100));
a3:=(low-llv(low,100))/(hhv(high,50)-llv(low,100));
a4:=HHVBARS(high,50)<LLVBARS(low,100);
a5:=a1 and a2>0.5 and a3>0.3 and a4;
a6:=count(a5,20)=1;
江恩回调选股:if(a6 and a5 ,60,0),stick,linethick2,colorf00ff0;
drawtext(江恩回调选股,50,'江恩回调选'),colorf0f000;


============================
{炮弹}
{参数描述: N(1,30,15)  M(1,50,32) }
Var1h:=DMA(AMOUNT/VOL/100, VOL/CAPITAL);
Var2h:=MA(WINNER(HIGH)-WINNER(Var1h), 15);
Var3h:=MA(WINNER(LOW)-WINNER(Var1h),32);
Var4h:=Var3h-Var2h;
火箭:if(REF(Var4h,2)<REF(Var4h,1) AND REF(Var4h,1)>Var4h AND Var4h>0 AND
Var4h*10>1,80,0),stick,color00ff00;
DRAWTEXT(火箭,70,'火箭'),colorf00ff0;
导弹:if(REF(Var4h,2)<REF(Var4h,1) AND REF(Var4h,1)>Var4h AND Var4h>0 AND
Var4h*10<1 AND Var4h*10>0.55,45,0),stick,colorred;
drawtext(导弹,40,'导弹'),coloryellow;
炮弹:if (REF(Var4h,2)<REF(Var4h,1) AND REF(Var4h,1)>Var4h AND Var4h>0 AND
Var4h*10<=0.55,60,0),stick,colorf0f000;
drawtext(炮弹,55,'炮弹'),color000099;


============================
{波段雄鹰}
Var1a:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var2a:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
Var3a:=SMA(SMA(Var2a,3,1),3,1);
Var4a:=EMA(Var3a,5);
Var5a:=LLV(LOW,26);
Var6a:=HHV(HIGH,34);
Var7a:=EMA((CLOSE-Var5a)/(Var6a-Var5a)*4,4)*25;
var8a:=(2*c+h+l)/4;
var9a:=llv(low,9);
var10a:=hhv(high,9);
Var2w:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
MW:= EMA(Var2w,3);
Var3w:=EMA(Var2w,7);
M1:= EMA(Var3w,5);
mb1:=CROSS(MW,M1) AND M1<20;
mg1:=if(CROSS(M1,MW) AND REF(MW,1)>80,80 ,0) ;
波段:=ema((var8a-var9a)/(var10a-var9a)*100,9),colorRED;
b1:=ema(0.667*ref(波段,1)+0.333*波段,2),color00ff00;
stickline(波段>b1,波段,b1,10,1),colorred;
stickline(波段<=b1,波段,b1,10,1),color00ff00;
波段雄鹰顶:if((BARSLAST(mg1>0)<2),80,100),color00ff00;
波段雄鹰底:IF((mb1),20,0),linethick2,coloryellow;
drawtext(波段雄鹰底,25,'★'),colorf00ff0;
drawtext(波段雄鹰底,15,'波段雄鹰底'),colorf0f000;
drawicon((BARSLAST(mg1>0)<2),80,2);
drawtext((BARSLAST(mg1>0)<2),90,'波段雄鹰顶');


============================
{百万预警}
Var1p:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;
Var2p:=SMA(Var1p,7,1);
Var3p:=SMA(Var2p,5,1);
百万预警:IF(CROSS(Var2p,Var3p) AND Var2p<20,85,0),linethick2 , color000999;
drawtext(CROSS(Var2p,Var3p) AND Var2p<20,75,'百万预警'),colorf00ff0;
drawtext(CROSS(Var2p,Var3p) AND Var2p<20,90,'★'),colorred;


============================
{漫步青云}
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  := EMA(DIFF,27);
dje1:=DIFF>=0 and DEA>=0 and CROSS(DIFF,DEA);
a5a:=MA(CLOSE,5)>MA(CLOSE,10);
v5a:=VOL>MA(VOL,5) and MA(VOL,5)>MA(VOL,10);
漫步青云:if(dje1 and a5a AND V5a AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1),60,0),colorf0f000;
drawtext(漫步青云,50,'漫步青云' ),coloryellow;

{CES}
Var00:=LWINNER(1,CLOSE);
Var1:=FORCAST(Var00,10);
Var2:=MA(Var1,3);
Var3:=MA(Var2,12);
Var4:=MA(Var3,16);
Var5:=MA(Var4,31);
Var6:=MA(Var5,55);
Var7:=Var5; Var8:=Var4>Var2*1.11 AND Var3>Var2*1.095;
Var9:=Var2>Var1*0.95;
Var1h:=INDEXC;
Var2h:=MA(Var1h,6);
Var3h:=MA(Var1h,24);
Var4h:=MA(Var1h,32);
Var5h:=MA(Var1h,62);
Var6h:=MA(Var1h,105);
Var7h:=Var5h; Var8h:=Var4h>Var2h*1.11 AND Var3h>Var2h*1.095;
Var9h:=Var2h>Var1h*0.95;
pt:=(if(h=l and c=o and l=c and c>0 and ref(h,1)=ref(l,1) and ref(c,1)=ref(o,1)
and ref(h,1)=ref(c,1) and ref(c,1)>0,0,1))>0;
CES:if((Var7h AND Var8h AND Var9h AND CLOSE/COST(8)<=0.7985
and (count(c=l,4)<3 or c>ref(c,1)))and pt or
Var7 and Var8 and Var9 and CLOSE/COST(5)<=0.8 AND
((Var1>OPEN OR Var1>REF(OPEN,1) OR
REF(Var1,1))),90,0),stick,linethick4,colorred;
drawicon(CES,90,1);


============================
{黑马初选}
黑马初选:if(VOL/240>REF(VOL,30)*1.2/240*1.5 AND CLOSE>LOW*1.06 AND CLOSE>REF(MA(CLOSE,3),1) AND MA(CLOSE,3)>REF(MA(CLOSE,3),1) AND "KD.K"(9,3,3)<50,50,0),colorf00ff0;
drawicon(黑马初选,60,1);
drawtext(黑马初选,40,'黑马初选'),colorf0f000;

============================
{蛟龙出海}
Var1b:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,15)-LLV(LOW,9))*100;
Var2b:=SMA(Var1b,3,1);
Var3b:=SMA(Var2b,3,1);
Var4b:=CLOSE/MA(CLOSE,3)>=1.05 AND MA(VOL,3)/MA(VOL,20)>1.5 AND COUNT(Var2b<20,20)>=1;
蛟龙出海:if(Var4b AND COUNT(Var4b,5)=1,60,0),color00ff00;
drawtext(蛟龙出海,50,'蛟龙出海'),colorred;


============================
{百万探庄}
Var1c:=MA(WINNER(CLOSE),9)*100;
百万探庄:if(CROSS(Var1c,2.5)*85,80,0),linethick2 , coloryellow,stick;
drawtext(百万探庄,70,'百万探庄'),colorred;


============================
{组合底部}
cci:="cci"(14);
a:=ref(c,1);
rsi:=sma(max(c-a,0),6,1)/sma(abs(c-a),6,1)*100;
a1:=c-ma(c,5)/ma(c,5)*100<1;
a2:=c-ma(c,13)/ma(c,13)*100<-10;
a3:=c-ma(c,34)/ma(c,34)*100<-15;
a4:=rsi<18;
a5:=cci<-120;
组合底部:if(a1 and a2 and a3 and a4 and a5,40,0),colorred;
drawicon(组合底部,43,1);
drawtext(组合底部,30,'组合底部'),colorf0f000;


============================
{雨点}
Var1b:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Var2b:=REF(Var1b,1);
Var3b:=SMA(MAX(Var1b-Var2b,0),10,1)/SMA(ABS(Var1b-Var2b),10,1)*100;
雨点星星:if(COUNT(Var3b<20,5)>=1 AND COUNT(Var1b=LLV(Var1b,10),10)>=1
AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1),1,0),colord480ad;
drawtext(雨点星星,100,'★'),colord480ad;


============================
{草原黑马}
{n(1,100,38) n1(1,100,5) n2(1,100,13)}
Var1a:(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80,colorblue;
stickline(var1a>0,0,100,8,0),colorfffcc0;


============================
{底部反转}
Var1:=MA(CLOSE,26);
Var2:=Var1+2*STD(CLOSE,26);
Var3:=Var1-2*STD(CLOSE,26);
Var4:=CLOSE>OPEN;
Var5:=(HIGH-CLOSE)/OPEN;
Var6:=(CLOSE-OPEN)/OPEN;
Var7:=Var4 AND Var5/Var6<0.5;
Var8:=CROSS(CLOSE,Var3) AND LLV(Var3,3)=LLV(Var3,90) AND Var7;
底部反转:if(Var8 AND REF(BARSLAST(Var8),1)>10,70,0),linethick3,colorf0f000;
drawtext(底部反转,60,'底部反转'),,color1373c0;
drawtext(底部反转,75,'★'),colorred;


============================
{中短底都有}
{p1(1,100,15) p2(1,100,33) p3(10,250,29) p4(10,100,28)}
aa:=(hhv(high,29)/ref(close,1))>(1+28/100);
bb:=dma(amount/vol/100,vol/capital);
cc:=bb-bb*15/100;
中短底都有:if(LOW<cc and VOL/MA(VOL,5)>1
AND CLOSE/OPEN>=(1+33/10/100 ) AND vol>ma(vol,5)* 15/10 AND aa,40,0),stick ,linethick4,colorred;
drawtext(中短底都有,30,'中短底都有'),color00ff00;
drawicon(中短底都有,45,1);


============================
{剑客四,雪飞指标选股}
BIAS1 := (CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2 := HHV((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,200);
m1:= bias1=bias2 ;
m2:= v>ma(v,5) ;
m3:= ref(bias1,1)<ref(bias2,1) ;
m4:=m1 and m2 and m3;
指标选股XF:if(m4,1,0),color0097de;
drawtext(指标选股XF,85,'★'),color0097de;
stickline(var1a<=0,Var1a,100,8,0),colorfffcc0;
stickline(var1a,var1a,0,8,0),colorgreen;
B1:= SMA(Var1a,7,1),;
Var2a:=SMA(B1,5,1);
E1:= IF(CROSS(B1,Var2a) AND cross(ma(c,5),ma(c,13) and b1>50) ,Var2a*2,Var2a),;
VAR4a:= EMA(CLOSE,8);
VAR5a:= EMA(CLOSE,20);
草原黑马买入:if(CROSS(MA(CLOSE,1),MA(CLOSE,38)) and b1-e1>2 and var4a>var5a ,60,0),linethick2,color00ff00;
drawtext(草原黑马买入,50,'草原黑马'),colorred;

============================
{紧追感情}
Var1d:=(CLOSE-LLV(CLOSE,21))/LLV(CLOSE,21)*1000;
Var2d:=(CLOSE+OPEN)/2;
Var3d:=(HIGH+LOW)/2;
Var4d:=IF(CLOSE>REF(CLOSE,1),MAX(Var2d,Var3d),MIN(Var2d,Var3d));
Var5d:=SUM(Var4d*VOL,21)/SUM(VOL,21);
Var6d:=VOL/CAPITAL*100;
VarAd:=(CLOSE-Var5d)/Var5d*100<-16 AND CLOSE/HHV(CLOSE,50)<=0.8 AND CLOSE/LLV(CLOSE,5)<1.2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>-11 AND Var6d<=10 AND COUNT(Var1d>500,60)<1 AND FINANCE(7)<=80000;
紧追感情:if(VarAd AND COUNT(VarAd,5)>=1,20,0),stick,linethick3,colorf00ff0;
drawtext(紧追感情,25,'▲'),colorf00ff0;
drawtext(紧追感情,15,'紧追感情'),color000999;


============================
{强势股}
{N(5,250,20 M(15,100,20)}
Var1C:=(CLOSE-REF(OPEN,20))/REF(OPEN,20);
Var2C:=(INDEXC-REF(INDEXO,20))/REF(INDEXO,20);
强势股:if(Var1C>0 AND Var2C>0 AND Var1C/Var2C>=20/10 OR Var1C>Var2C AND Var2C=0 OR 0>Var1C AND Var1C>Var2C AND Var2C/Var1C>=20/10,1,0),colorred;
drawtext(强势股,10,'▲'),colorred;


============================
{魔法1:我调整了参数,成功率59.7%,净利23%}
{参数描述: N(1,100,6)M1(2,40,2)M2(2,40,2)X(0,10,2)}
100;
Var1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
Var2:=SMA(Var1,13,1);
Var3:=SMA(Var2,5,1);
Var4:=3*Var2-2*Var3;
魔法1:if(Var3<100 AND Var4>Var2*1.03 AND Var2>Var3*1.01 AND Var4>REF(Var4,1)*1.05 AND Var2>REF(Var2,1)*1.005 AND Var3>REF(Var3,1)*1.005 AND CLOSE>OPEN*(1+2/100) AND VOL>MA(VOL,5)*1.2,50,0),coloryellow;
drawtext(魔法1,45,'魔法1'),color00ff00;


============================
{抄底}
Var1a:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100<-30;
Var2a:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-27;
Var3a:=Var1a AND Var2a;
抄底:if(Var3a AND COUNT(Var3a,2)=1  AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07,85,0),stick,linethick3,colorred;
drawtext(抄底,85,'★'),coloryellow;
drawtext(抄底,75,'抄底'),coloryellow;


============================
{收盘价逃顶}
V1:=MA(C,5)=HHV(MA(C,5),20);
v2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(c,1)>REF(C,1),2)=2;
收盘价逃顶:if(v1 and V2 and V3 and V4,90,0),linethick2,colorblue;
drawtext(收盘价逃顶,80,'收盘价逃顶'),color000999;


============================
{三均线粘合}
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);

p1:=abs(ma1-ma2)+abs(ma2-ma3);
aa:=p1/c<20/1000 and ma1>ref(ma1,1) and ma2>ref(ma2,1) and ma1<ma3 and ma2<ma3;
三均线粘合:if(aa,22,0),linethick2,color000999;
drawtext(aa,21,'三均线粘合'),color00ff00;


============================
{天胜至尊}

100;
0;
Var1:=IF(YEAR>2094,0,1) OR IF(YEAR>2093 AND MONTH>=1,0,1);
Var2:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
Var3:=(CLOSE-Var2)/Var2*100;
Var4:=REF(Var3,1)<-40 AND Var3>REF(Var3,1) AND REF(Var3,1)<REF(Var3,2) AND Var3-REF(Var3,1)>2.5;
Var5:=(CLOSE-OPEN)/OPEN*100;
Var6:=REF(CLOSE,1);
Var7:=SMA(MAX(CLOSE-Var6,0),6,1)/SMA(ABS(CLOSE-Var6),6,1)*100;
Var8:=COUNT(Var7<20,20)>=1;
Var9:=Var5>9 AND Var8;
VarA:=100*WINNER(OPEN);
VarB:=100*WINNER(CLOSE);
VarC:=VarB-VarA;
VarD:=VarC>=30;
VarE:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VarF:=REF(CLOSE,1);
Var10:=SMA(MAX(CLOSE-VarF,0),5,1)/SMA(ABS(CLOSE-VarF),5,1)*100;
Var11:=COUNT(Var10<20,20)>=1;
Var12:=VarE AND Var11;
Var13:=MA(CLOSE,4);
Var14:=MA(CLOSE,10);
Var15:=MA(CLOSE,20);
Var16:=MA(CLOSE,25);
Var17:=COUNT(CROSS(Var14,Var15),2)=1;
Var18:=COUNT(CROSS(Var13,Var16),2)=1;
Var19:=Var17 AND Var18;
Var1A:=Var12 AND VarD AND Var19;
Var1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;
Var1C:=CLOSE<Var1B AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;
天胜至尊:if(Var4 OR Var9 OR Var1A OR Var1C*Var1,80,0),stick,linethick2,colorred;
drawtext(Var4 OR Var9 OR Var1A OR Var1C*Var1,70,'天胜至尊'),coloryellow;


============================
{CN抄底}
Var1g:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
Var2g:=REF(HIGH,10)/CLOSE>1.35;
抄底: if((CLOSE-Var1g)/Var1g*100<-30 AND Var2g,70,0),coloryellow;
drawtext((CLOSE-Var1g)/Var1g*100<-30 AND Var2g,60,'抄底'),colorf0f000;


============================
{回调必杀}
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
A1 :=CLOSE/MA(CLOSE,3)>=(1+0.07) AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
A2 :=COUNT(RSI<20,20)>=1;
回调必杀:if(A1 AND A2,60,0),stick,color00ff00;
drawtext(A1 AND A2,50,'回调必杀'),colorred;


============================
{千年等一回}
Var1k:=INDEXC;
Var2k:=MA(Var1k,6);
Var3k:=MA(Var1k,24);
Var4k:=MA(Var1k,32);
Var5k:=MA(Var1k,62);
Var6k:=MA(Var1k,105);
Var7k:=Var5k<REF(Var5k,1) AND Var6k<REF(Var6k,1) AND Var5k<Var6k*0.98;
Var8k:=Var4k>Var2k*1.11 AND Var3k>Var2k*1.095;
Var9k:=Var2k>Var1k*0.95;
VarAk:=CLOSE/MA(CLOSE,48)*100<73;
VarBk:=CLOSE/MA(CLOSE,50)*100<76;
VarCk:=HIGH>LOW*1.078;
VarDk:=VarCk AND COUNT(VarCk,4)>2;
千年等一回:if((VarDk AND (VarAk OR VarBk) AND Var7k AND Var8k AND Var9k AND CLOSE/COST(8)<=0.81  AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1))),90,0),stick,linethick5,coloryellow;
drawtext(千年等一回,85,'千年等一回'),color00ff00;


============================
{惊天动地}
Var1h:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
Var2h:=SMA(Var1h,3,1);
Var3h:=SMA(Var2h,5,1);
Var4h:=3*Var2h-2*Var3h;
Var5h:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
Var6h:=SMA(Var5h,3,1);
Var7h:=SMA(Var6h,3,1);
Var8h:=3*Var6h-2*Var7h;
Var9h:="BOLL"(26,2);
VarAh:="MACD"(26,12,9);
VarBh:="CYS";
VarCh:=IF(DATE>1300415,0,1);
VarDh:=REF(VarBh,1)<-17.5 AND REF(VarBh,1)>-36 AND CLOSE*VarCh<10 AND CLOSE*VarCh/REF(CLOSE,1)>0.935 AND CROSS(Var4h,Var6h);
惊天动地:if(VarDh/VarBh,50,0),color00ff00;


============================
{强势觅踪}
Var1j:=VOL/CAPITAL>=0.02 AND NOT(REF(VOL/CAPITAL>=0.5,1)) AND CLOSE/OPEN>1.05 AND
HIGH/LOW<CLOSE/OPEN+0.018;
Var2j:=CLOSE/REF(OPEN,2)>1.15;
Var3j:=(REF(CLOSE,2)-LLV(LOW,13))/(HHV(HIGH,13)/1.15-LLV(LOW,13))>0.2;
Var4j:=Var1j AND Var2j AND Var3j;
强势觅踪:if(Var4j AND COUNT(Var4j,60)=1,45,0),colorred;
drawtext(强势觅踪,35,'强势觅踪'),coloryellow;


============================
{猎杀潜航}
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORYELLOW;
底部:=7;
猎杀潜航:IF(CROSS(趋势,底部),70,0),stick,COLORf0f000,linethick3;
drawtext(猎杀潜航,60,'猎杀潜航'),colorred;


============================
{逢底必抄}
b1:=REF(CLOSE,2);
b2:=SMA(MAX(CLOSE-b1,0),7,1)/SMA(ABS(CLOSE-b1),7,1)*100;
逢底必抄:if(b2<19,30,0),linethick2,color00ff00;
drawtext(逢底必抄,25,'逢底必抄'),coloryellow;


============================
{寻找底部}
aa:= llv(l,21)=llv(l,73) and count(v>ma(v,5)*1.5,5)>=2
and hhv(c/o,30)>=1.07  and c/o>=1.05;
寻找底部:if(count(aa,13) and aa,60,0),stick,linethick2,colorf00ff0;
drawtext(寻找底部,50,'寻找底部'),colorf0f000;


============================
{AA-100%}
Var3:=INDEXC;
Var4:=MA(Var3,8);
Var5:=MA(Var3,22);
Var6:=MA(Var3,28);
Var7:=MA(Var3,73);
Var8:=MA(Var3,106);
Var9:=Var7<REF(Var7,1) AND Var8<REF(Var8,1) AND Var7<Var8*0.98;
VarA:=Var6>Var4*1.11 AND Var5>Var4*1.095;
VarB:=Var4>Var3*0.95;
VarC:=Var9 AND VarA AND VarB AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
百分之百: if(VarC*6,60,0),coloryellow;
DRAWICON(VarC*6>0,60,1);
DRAWTEXT(VarA*6>0,40,'100%获利'),colorred;


============================
{千夫指}
Var1a:=120;
Var2a:=IF(BARSCOUNT(CLOSE)>=Var1a,(CLOSE-LLV(LOW,Var1a))/(HHV(HIGH,Var1a)-LLV(LOW,Var1a))*100,40);
Var3a:=MA(Var2a,20);
Var4a:=BARSCOUNT(CLOSE)>=Var1a AND CROSS(Var2a,Var3a) AND Var3a<40 AND LLV(Var2a,10)<11 OR Var2a<2.2;
Var5a:=BARSCOUNT(CLOSE)>=Var1a AND CROSS(Var3a,Var2a) AND Var3a>85 AND HHV(Var2a,10)>95 OR Var2a>97.5;
千夫指买入: if(REF(COUNT(Var4a,10),1)=0 AND Var4a,40,0),stick,colorf0f000;
千夫指卖出: if(REF(COUNT(Var5a,10),1)=0 AND Var5a,50,0),stick,color2255ff;
drawtext(REF(COUNT(Var4a,10),1)=0 AND Var4a,35,'千夫指买入'),coloryellow;
drawtext(REF(COUNT(Var5a,10),1)=0 AND Var5a,40,'千夫指卖出'),color00ff00;


============================
{千夫指}
Var1a:=120;
Var2a:=IF(BARSCOUNT(CLOSE)>=Var1a,(CLOSE-LLV(LOW,Var1a))/(HHV(HIGH,Var1a)-LLV(LOW,Var1a))*100,40);
Var3a:=MA(Var2a,20);
Var4a:=BARSCOUNT(CLOSE)>=Var1a AND CROSS(Var2a,Var3a) AND Var3a<40 AND LLV(Var2a,10)<11 OR Var2a<2.2;
Var5a:=BARSCOUNT(CLOSE)>=Var1a AND CROSS(Var3a,Var2a) AND Var3a>85 AND HHV(Var2a,10)>95 OR Var2a>97.5;
千夫指买入: if(REF(COUNT(Var4a,10),1)=0 AND Var4a,40,0),stick,colorf0f000;
千夫指卖出: if(REF(COUNT(Var5a,10),1)=0 AND Var5a,50,0),stick,color2255ff;
drawtext(REF(COUNT(Var4a,10),1)=0 AND Var4a,35,'千夫指买入'),coloryellow;
drawtext(REF(COUNT(Var5a,10),1)=0 AND Var5a,40,'千夫指卖出'),color00ff00;


============================
{RSI二线差}
aa:="rsi.rsi1"(3,14,24);
bb:="rsi.rsi2"(3,14,24);
二线差RSI:if((bb-aa)/aa>n,30,0),stick,linethick2,color00ff00;
drawtext((bb-aa)/aa>n,25,'RSI二线差'),colorf0f000;


============================
{横盘起动}
A1:=100*(WINNER(1.1*C)-WINNER(0.9*C));
A2:=((CLOSE-LOW)/(HIGH-LOW)+(CLOSE-HIGH)/(HIGH-LOW))*VOL;
A3:=SUM(A2,10)/10000;
Var1c:=AMOUNT/VOL/100;
Var2c:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
Var3c:=SUM(AMOUNT,5)/Var1c/100;
Var4c:=SUM(AMOUNT,13)/Var1c/100;
Var5c:=SUM(AMOUNT,34)/Var1c/100;
CYC5:=DMA(Var2c,VOL/Var3c);
CYC13:=DMA(Var2c,VOL/Var4c);
CYC34:=DMA(Var2c,VOL/Var5c);
CYS13:=(CLOSE-CYC13)/CYC13*100;
CYR13:=CYC13/REF(CYC13,1)*120-120;
MA5:=MA(C,5);
B:=VOL*100/CAPITAL;
AAa:=COUNT(A1>60,20)=20;
横盘启动:if(AAa AND CYC5>CYC13 AND CYC13>CYC34,10,0),linethick2,colorblue;


============================
{上升斜率ma}
aa2:=ma(c,5);
bb2:=ref(ma(c,5),1);
上升斜率ma:if((aa2-bb2)/bb2>n2/1000,30,0),color00ff00;
drawtext((aa2-bb2)/bb2>n2/1000,20,'上升斜率ma'),color000999;


============================
{飞鹰双翼}
Var1g:=CLOSE/MA(CLOSE,40)*100 < 78;
Var2g:=CLOSE/MA(CLOSE,60)*100 < 74;
Var3g:=HIGH > LOW*1.051;
Var4g:=Var3g AND COUNT(Var3g,5) > 1;
飞鹰双翼:if(Var4g AND (Var1g OR Var2g),40,0),colorf0f000;
drawtext(Var4g AND (Var1g OR Var2g),30,'飞鹰双翼'),coloryellow; 

  评论这张
 
阅读(56)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017